• @redcalcium@lemmy.institute
    link
    fedilink
    701 month ago

    I’m truly torn with this. The first one seems sensible (action -> target) and easier to read and reason about (especially with long names), while the other one looks more organized, naturally sortable and works great with any autocompletion system.

        • bitwolf
          link
          9
          edit-2
          1 month ago

          Also a programmer and think method names would be conducive using little endian.

          TopicGet()
          TopicCreate()
          TopicDelete()
          

          Writing this I realize we do this implicitly in some instances.

          http.Get() -> httpGet()
          http.Post() -> httpPost()
          
    • @kunaltyagi@programming.dev
      link
      fedilink
      151 month ago

      We need a new framework, one that allows universal lookup, and makes life easier

      x = _.dialog.file.open
      y = _.open.file.dialog
      z = _.file.open.dialog
      a = _.file.dialog.open
      

      Once done, the formatter simply changes everything to _.open.file.dialog

      Let’s get this done JS peeps

      \s